Stale Practices

Incident Report for dataco.dental

Resolved

This incident has been resolved.
Posted Feb 19, 2026 - 16:09 EST

Monitoring

As a result of the previous incident, many practices will be flagged as stale. Our team is implementing a fix to get the practices in a healthy state.
Posted Feb 19, 2026 - 09:42 EST
This incident affected: PIMS Data Connectivity.