SupportCo Infrastructure Issues

Incident Report for dataco.dental

Resolved

This incident has been resolved.
Posted Feb 19, 2026 - 09:27 EST

Investigating

We are currently having infrastructure issues which may impact SupportCo functionality.
Posted Feb 19, 2026 - 09:23 EST
This incident affected: SupportCo.